WordPress 2.8.1 beta 1 でプラグイン管理でアクセス権に関するエラーが発生

このページは約 1分35秒で読めます。

橋本浩一のなまぐさブログ さんより Post Templatesプラグイン WordPress 2.8と相性悪し… という Trackback をいただいて、ほう、そんなこともあるのかと自分の環境で実験してみたらひどい目に遭ったのでメモ。

件の Post Templates やAdd-Meta-Tagsなど私の環境で使っているプラグインの一部が WordPress 2.8.1 beta 1 に更新するとさらなる不具合が発生してました。

該当プラグインの管理画面へアクセスしようとすると「このページにアクセスするための十分なアクセス権がありません。」と表示され、例えば Post Templates ではテンプレートの編集や新規作成が行えなくなってしまいます。

2.8 で上書きし直したら編集できるようになったので、これは 2.8.1 beta 1 でのエンバグってことでしょうか?

WordPress の Trac 見てみたけどそれっぽいチケットないのかなあ、プラグインの方の不具合は散見されてるようだからどちらが原因かの追求は早くされそうですが、正式版でもこの状態だとバージョンアップできなくて困ってしまいますね。

WordPress 2.8.1 で改修された「明示的な権限チェックを行わないプラグインに対するセキュリティを強化」に該当するようですね。

Post Templates 3.4.0 ではこの現象も改善されています。

スポンサーリンク

Trackback URL

No Trackback to WordPress 2.8.1 beta 1 でプラグイン管理でアクセス権に関するエラーが発生

Still quiet here.

Comments are closed.